Apache Subversion Team Releases 1.7.9 and 1.6.21

The Apache Subversion team has announced two new releases: Subversion 1.7.9 and 1.6.21.

Subversion 1.7.9 improves the error messages for svn:date and svn:author props, and it improves the logic in mod_dav_svn’s implementation of lock, as well as a list of other features and fixes:

  • Doxygen docs now ignore prefixes when producing the index

  • Javahl status api now respects the ignoreExternals boolean

  • Executing unnecessary code in log with limit is avoided

  • A fix for a memory leak in `svn log` over svn://

  • An incorrect authz failure when using neon http library has been fixed

  • A fix for an assertion when rep-cache is inaccessible

More information on Apache Subversion 1.7.9 can be found in the Changes file.

Meanwhile, Subversion 1.6.21 improves memory usage when committing properties in mod_dav_svn, and also improves logic in mod_dav_svn’s implementation of lock, alongside bug fixes including:

  • A fix for a post-revprop-change error that could cancel commits

  • A fix for a compatibility issue with g++ 4.7

More information on Apache Subversion 1.6.21 can be found in the Changes file.

Both versions can be downloaded free via the WANdisco website.

1 Response to “Apache Subversion Team Releases 1.7.9 and 1.6.21”


  • SVN 1.7.9 has broken dependencies for debian squeeze on the wandisco repository.

    Currently running 1.7.8 from wandisco.

    #cat /etc/apt/sources.list.d/wandisco.list
    deb http://opensource.wandisco.com/debian squeeze svn17

    new versio nis held back due to dependency issues

    # apt-get install libsvn1
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    libsvn1 : Depends: libaprutil1 (>= 1.4.0) but 1.3.9+dfsg-5 is to be installed
    Depends: libdb5.1 but it is not installable
    Depends: libserf1 (>= 1.0) but it is not going to be installed
    PreDepends: multiarch-support but it is not installable

Leave a Reply